Funkcja logiczna jeżeli



Pobieranie 14.81 Kb.
Data27.04.2016
Rozmiar14.81 Kb.
Funkcja logiczna JEŻELI
Funkcja JEŻELI służy do przeprowadzania testów logicznych na wartościach i formułach.
=JEŻELI ( Warunek logiczny ; JeśliPrawda ; JeśliFałsz )

Jeśli warunek logiczny daje wartość PRAWDA - funkcja zwraca wartość JeśliPrawda, w przeciwnym wypadku (warunek równy FAŁSZ) - funkcja zwraca wartość JeśliFałsz.


PRZYKŁAD

komórka zawiera wartość 1



=jeżeli(A1=1;”tak”; ”nie”) w komórce pojawi się słowo „tak”

=jeżeli(A1=2;A1+1; A1-1) w komórce pojawi się liczba 0

Funkcja może mieć też postać:



=JEŻELI(Warunek; JeśliPrawda)

i wtedy wyliczana jest wartość JeśliPrawda lub w zwracana jest wartość FAŁSZ


PRZYKŁAD

komórka zawiera wartość 1



=jeżeli(A1=1;”tak”) w komórce pojawi się słowo „tak”

=jeżeli(A1=2;”tak”) w komórce pojawi się słowo „FAŁSZ”

Wartości JeśliPrawda i JeśliFałsz mogą zawierać konkretne liczby, teksty, daty, adresy komórek oraz dowolne formuły nawet zawierające ponowne wywołanie funkcji JEŻELI..


Podstawowe operatory logiczne

(w poniższych przykładach komórka A1 zawiera liczbę 1): wynik w komórce

= równe =JEŻELI(A1=1;1;0) 1

<> różne =JEŻELI(A1<>1;1;0) 0

< mniejsze =JEŻELI(A1<1;1;0) 0

> większe =JEŻELI(A1>1;1;0) 0



<= mniejsze lub równe =JEŻELI(A1<=1;1;0) 1

>= większe lub równe =JEŻELI(A1>=1;1;0) 1


Inne przykłady: (w komórce A1 znajduje się liczba 1)

=JEŻELI(A1=1;”TAK”;”NIE”) w komórce z formułą pojawi się napis TAK

=JEŻELI(A1<1;A1+1;A1-1) w komórce pojawi się liczba 0 (1-1)

=JEŻELI(A1<=1;A1+1;A1-1) w komórce pojawi się liczba 2 (1+1)
Zagnieżdżone jeżeli

=JEŻELI(A1>0;”Brak”; JEŻELI(A1=0;”Jeden”; „Dwa”))
Jeżeli w komórce A1 będzie liczba mniejsza od zera pojawi się napis Brak pierwiastków

Gdy będzie liczba zero - pojawi się napis Jeden pierwiastek. W pozostałych przypadkach (liczba większa od zera) pojawi się napis Dwa pierwiastki.



Funkcje logiczne NIE, ORAZ i LUB
Złożone warunki logiczne możemy opisywać za pomocą funkcji jeżeli zagnieżdżonych albo używać zaprzeczenia, sumy i iloczynu logicznego.
PRZYKŁADY

To samo zadanie - czy komórka A1 zawiera liczbą z przedziału <1..10> wykonamy trzema sposobami:



zagnieżdżenie

=JEŻELI(A1>=1;JEŻELI(A1<=10;A1;"poza");"poza")

iloczyn logiczny

funkcja ORAZ, gdzie warunek ma postać: ORAZ(A1>=1;A1<=10)



=JEŻELI(ORAZ(A1>=1;A1<=10);A1;”poza”)

suma logiczna

To samo za pomocą kombinacji NIE i LUB (logika matematyczna)



=JEŻELI(NIE(LUB(A1<1;A1>10));A1;"poza")
Sprawdzenie czy komórka A1 zawiera liczbę spoza przedziału 1..10

suma logiczna

=JEŻELI(LUB(A1<1;A1>10));”poza”; ”w przedziale”)


Pobieranie danych z innego arkusza

=Arkusz2!A1

Formuła znajduje się w komórce B2 na arkuszu o nazwie „Arkusz1” i pobiera informację z arkusza o nazwie „Arkusz2” z komórki A1 (z arkusza „Arkusz1” „zaglądamy” do komórki A1 na arkuszu „Arkusz2”)



Zadanie MLECZARNIA

Rolnicy oddają mleko do mleczarni, które badane jest ze względu na zawartość tłuszczu oraz określana jest tzw. klasa mleka. Na podstawie tych danych liczona jest wypłata składająca się z podstawowej stawki i dodatków. Oblicz na podstawie tabeli dodatki i wypłatę dla czterech krówek. Posługuj się współczynnikami zamieszczonymi w osobnej tabelce poniżej tabeli głównej (adresy bezwzględne), aby można było automatycznie przeliczać całą wypłatę po zmianie współczynników.

Stawka podstawowa:

- za jeden litr mleka rolnik otrzymuje 50 groszy (komórka B9)

Dodatki:

- jeżeli mleko zawiera mniej niż 3,5% tłuszczu (C10), to do każdego litra oddanego mleka rolnik otrzymuje dopłatę 4,5 grosza (B10)

- jeżeli mleko jest w klasie I lub E (komórki C11 i D11), to do każdego litra mleka rolnik otrzymuje dopłatę 6 groszy (B11)

- jeżeli rolnik oddał więcej niż 700 litrów mleka (C12), to do każdego litra ponad te 700 rolnik otrzymuje dopłatę 4 groszy (B12)



Formuły będą pokazane dla wiersza 2, można je będzie kopiować na kolejne komórki w dół
ZA LITRY - komórka E2

=B2*$B$9/100

dzielimy przez 100 ponieważ wynik chcemy mieć w złotówkach
ZA TŁUSZCZ - komórka F2

=JEŻELI(C2<$C$10;B2*$B$10/100;0)

gdy tłuszcz nie spełnia wymagań dopłata równa 0
ZA KLASĘ - komórka G2

=JEŻELI(LUB(D2=$C$11;D2=$D$11);B2*$B$11/100;0)

zapis LUB(D2=$C$11;D2=$D$11) oznacza, że klasa musi być równa I lub E
PREMIA - komórka H2

=JEŻELI(ORAZ(B2>$C$12;LUB(D2=$C$11;D2=$D$11));(B2-$C$12)*$B$12/100;0)

zapis ORAZ(B2>$C$12;LUB(D2=$C$11;D2=$D$11) oznacza, że mleka powinno być więcej niż 700 litrów i musi być w klasie E lub I. Ponieważ ten ostatni warunek zbadany został w kolumnie G można ten złożony zapis zastąpić nieco prostszym:

ORAZ(B2>$C$12;G2>0) klasa jest dobra, gdy miał dopłatę za klasę (większa od zera)

Zapis (B2-$C$12)*$B$12/100 oznacza kwotę dopłaty za dodatkowe litry ponad 700 (B2-$C$12)
WYPŁATA - komórka I2

=SUMA(E2:H2)


(UWAGA: dwie połówki miesiąca na przykładzie arkusza MLEKO)


©absta.pl 2016
wyślij wiadomość

    Strona główna